Android devices (PDF)

If your Android Smartphone is not listed it is possible for it to be compatible if it meets the following requirements:

  • Android 4.3 OS and above
  • Bluetooth 4.0 capable

Apple devices (PDF)

Requires iPhone to be running latest available OS version

Windows 10 Phone (PDF)

If your Windows Smartphone is not listed it is possible for it to be compatible if it meets the following requirements:

  • Windows 10 Mobile and above
  • Bluetooth 4.0 capable

Võrdle 0